Hero App - App performance degraded and an issue relating to appointment cancellations – Incident details

All systems operational

App performance degraded and an issue relating to appointment cancellations

Resolved
Degraded performance
Started 19 days agoLasted 2 days

Affected

Hero Features

Degraded performance from 12:56 PM to 3:30 PM

Admin Portal

Degraded performance from 12:56 PM to 3:30 PM

Patient Booking Service

Degraded performance from 12:56 PM to 3:30 PM

Integrations

Degraded performance from 12:56 PM to 3:30 PM

EMIS integration

Degraded performance from 12:56 PM to 3:30 PM

Updates
  • Resolved
    Resolved

    This issue has now been resolved.

    Booking and cancellation outage (28 April)

    Bookings and cancellations made through the EMIS-led path were intermittently failing causing a number of bookings to be illegitimately cancelled, with some practices also seeing diary dropouts. Resolved on the afternoon of 28 April after deploying a fix and refreshing availability data.

    Duplicate appointments (29 to 30 April)

    Some clinicians saw duplicate appointments in their diary as a knock-on from the 28 April recovery. We stopped further duplicates being created on the morning of 29 April, cleared the bulk by end of day, and processed the remainder into 30 April.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating
    We are currently investigating this incident.