Hero App - Hero Health Outage – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Report an issue
Get updates
Dark mode
All systems operational
Hero Health Outage
Resolved
Operational
Started 18 days ago
Lasted about 2 hours
Updates
Resolved
February 24, 2025 at 5:30 PM
Resolved
February 24, 2025 at 5:30 PM
This incident has been resolved.
Monitoring
February 24, 2025 at 3:03 PM
Monitoring
February 24, 2025 at 3:03 PM
A fix has been implemented and we are monitoring the results.