Hero App - App performance issues – Incident details

All systems operational

App performance issues

Resolved
Degraded performance
Started about 1 month agoLasted about 7 hours

Affected

Hero Features

Degraded performance from 8:20 AM to 3:02 PM

Admin Portal

Degraded performance from 8:20 AM to 3:02 PM

Hero API

Degraded performance from 8:20 AM to 3:02 PM

Updates
  • Resolved
    Resolved

    We have identified and resolved the root cause of this morning's performance issues. Under high load, a backlog of conflicting operations caused a cascading slowdown across the app. A fix has been deployed and the service is performing normally. Booking accuracy was not affected.

  • Monitoring
    Monitoring

    Performance is improving but has not yet fully returned to normal. We are confirming the root cause and will share further updates shortly.

  • Investigating
    Investigating

    Some users may be experiencing slow load times or missing data within the app as well as long response times on our API for API users. Our team is aware and actively investigating.