Hero App - Hero Admin portal is currently down – Incident details

All systems operational

Hero Admin portal is currently down

Resolved
Major outage
Started 16 days agoLasted about 2 hours

Affected

Hero Features

Major outage from 8:21 AM to 9:10 AM, Operational from 9:10 AM to 10:28 AM

Admin Portal

Major outage from 8:21 AM to 9:10 AM, Operational from 9:10 AM to 10:28 AM

Patient Booking Service

Major outage from 8:21 AM to 9:10 AM, Operational from 9:10 AM to 10:28 AM

Hero Toolbar

Major outage from 8:21 AM to 9:10 AM, Operational from 9:10 AM to 10:28 AM

Updates
  • Postmortem
    Postmortem

    What happened: Between 8.20am and 9.00am this morning, you may have experienced difficulty accessing Hero Health or received error messages. This was caused by our database being overwhelmed by high volumes of background data processing.

    Resolution: Our technical team identified the source of the overload and took immediate action to resolve it. Full system access was restored at 9.10am, and we've been monitoring performance closely since then to ensure stability.

    Next steps: We will plan additional safeguards to prevent similar issues from occurring in the future, including optimising our data processing schedules and removing unnecessary background tasks.

  • Resolved
    Resolved

    Our team has determined that this morning's outage was caused by an unusually high volume of data processing activities occurring simultaneously. This created a backlog that temporarily overwhelmed our database, preventing users from accessing the system.

    The issue has been resolved and normal service has been restored.

  • Investigating
    Investigating
    We are currently investigating this incident.