Hero App - Unable to raise invoices – Incident details

Experiencing partially degraded performance

Unable to raise invoices

Resolved
Major outage
Started about 2 months agoLasted 18 minutes

Affected

Hero Features

Major outage from 1:42 PM to 2:00 PM

Admin Portal

Major outage from 1:42 PM to 2:00 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We are currently investigating an issue where users are unable to raise invoices across the platform.stigating this incident.